aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2011-08-06 20:37:28 +0300
committerLasse Collin <lasse.collin@tukaani.org>2011-08-06 20:37:28 +0300
commite9ed88126eee86e2511fa42681a5c7104820cf0a (patch)
treed63350425c2f29e50cf9f953aa7f2001f5e46d68 /configure.ac
parentFix exit status of "xzdiff foo.xz bar.xz". (diff)
downloadxz-e9ed88126eee86e2511fa42681a5c7104820cf0a.tar.xz
Run the scripts with the correct shell in test_scripts.sh.
The scripts are now made executable in the build tree. This way the scripts can be run like programs in test_scripts.sh. Previously test_scripts.sh always used sh but it's not correct if @POSIX_SHELL@ is set to something else by configure. Thanks to Jonathan Nieder for the patch.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 5247c979..37949a94 100644
--- a/configure.ac
+++ b/configure.ac
@@ -716,13 +716,13 @@ AC_CONFIG_FILES([
src/xzdec/Makefile
src/lzmainfo/Makefile
src/scripts/Makefile
- src/scripts/xzdiff
- src/scripts/xzgrep
- src/scripts/xzmore
- src/scripts/xzless
tests/Makefile
debug/Makefile
])
+AC_CONFIG_FILES([src/scripts/xzdiff], [chmod +x src/scripts/xzdiff])
+AC_CONFIG_FILES([src/scripts/xzgrep], [chmod +x src/scripts/xzgrep])
+AC_CONFIG_FILES([src/scripts/xzmore], [chmod +x src/scripts/xzmore])
+AC_CONFIG_FILES([src/scripts/xzless], [chmod +x src/scripts/xzless])
AC_OUTPUT