aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2009-07-05 22:25:17 +0300
committerLasse Collin <lasse.collin@tukaani.org>2009-07-05 22:25:17 +0300
commit96e4b257e101d72072d43e144897d92920270669 (patch)
tree5f1852c0c90b41b66dd0b24ba8719b68cea5d048 /configure.ac
parentUse @PACKAGE_HOMEPAGE@ in liblzma.pc.in. (diff)
downloadxz-96e4b257e101d72072d43e144897d92920270669.tar.xz
Major update to the xzgrep and other scripts based on
the latest versions found from gzip CVS repository. configure will try to find a POSIX shell to be used by the scripts. This should ease portability on systems which have pre-POSIX /bin/sh. xzgrep and xzdiff support .xz, .lzma, .gz, and .bz2 files. xzmore and xzless support only .xz and .lzma files. The name of the xz executable used in these scripts is now correct even if --program-transform-name has been used.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ce63eeee..86eac38e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -412,6 +412,12 @@ AC_SUBST([STATIC_LDFLAGS])
###############################################################################
echo
+gl_POSIX_SHELL
+if test -z "$POSIX_SHELL" ; then
+ AC_MSG_ERROR([No POSIX conforming shell (sh) was found.])
+fi
+
+echo
echo "Initializing Automake:"
AM_INIT_AUTOMAKE([1.10 foreign tar-v7 filename-length-max=99])
@@ -641,6 +647,10 @@ AM_CONDITIONAL([COND_GNULIB], test -n "$LIBOBJS")
# Add default AM_CFLAGS.
AC_SUBST([AM_CFLAGS])
+# This is needed for src/scripts.
+xz=`echo xz | sed "$program_transform_name"`
+AC_SUBST([xz])
+
AC_CONFIG_FILES([
Doxyfile
Makefile
@@ -653,6 +663,10 @@ AC_CONFIG_FILES([
src/xz/Makefile
src/xzdec/Makefile
src/scripts/Makefile
+ src/scripts/xzdiff
+ src/scripts/xzgrep
+ src/scripts/xzmore
+ src/scripts/xzless
tests/Makefile
debug/Makefile
])