aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJia Tan <jiat0218@gmail.com>2024-02-23 20:57:59 +0800
committerJia Tan <jiat0218@gmail.com>2024-02-23 20:57:59 +0800
commitadaacafde6661496ca2814b1e94a3ba5186428cb (patch)
tree28164457659dbff02a9312f9746f5d76ac2add41 /configure.ac
parentxz: Fix Capsicum sandbox compile error. (diff)
downloadxz-adaacafde6661496ca2814b1e94a3ba5186428cb.tar.xz
Build: Define HAVE_MICROLZMA when it is configured.
Diffstat (limited to '')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4476c8b4..3676cd03 100644
--- a/configure.ac
+++ b/configure.ac
@@ -304,8 +304,13 @@ AC_ARG_ENABLE([microlzma], AS_HELP_STRING([--disable-microlzma],
for example, erofs-utils.]),
[], [enable_microlzma=yes])
case $enable_microlzma in
- yes | no)
- AC_MSG_RESULT([$enable_microlzma])
+ yes)
+ AC_DEFINE([HAVE_MICROLZMA], [1],
+ [Define to 1 if MicroLZMA support is enabled.])
+ AC_MSG_RESULT([yes])
+ ;;
+ no)
+ AC_MSG_RESULT([no])
;;
*)
AC_MSG_RESULT([])