aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2011-04-10 21:23:21 +0300
committerLasse Collin <lasse.collin@tukaani.org>2011-04-10 21:23:21 +0300
commit9f0a806aef7ea79718e3f1f2baf3564295229a27 (patch)
tree7d06008086bddd7a6c99a5c085e5ce5da44d87fa /configure.ac
parentliblzma: Make lzma_stream_encoder_init() static. (diff)
downloadxz-9f0a806aef7ea79718e3f1f2baf3564295229a27.tar.xz
Revise mythread.h.
This adds: - mythread_sync() macro to create synchronized blocks - mythread_cond structure and related functions and macros for condition variables with timed waiting using a relative timeout - mythread_create() to create a thread with all signals blocked Some of these wouldn't need to be inline functions, but I'll keep them this way for now for simplicity. For timed waiting on a condition variable, librt is now required on some systems to use clock_gettime(). configure.ac was updated to handle this.
Diffstat (limited to '')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c0099253..72ea6ccc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -435,6 +435,7 @@ if test "x$enable_threads" = xyes; then
LIBS="$LIBS $PTHREAD_LIBS"
AM_CFLAGS="$AM_CFLAGS $PTHREAD_CFLAGS"
CC="$PTHREAD_CC"
+ AC_SEARCH_LIBS([clock_gettime], [rt])
fi
echo