aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2020-02-05 19:33:37 +0200
committerLasse Collin <lasse.collin@tukaani.org>2020-02-05 19:33:37 +0200
commit986d8c9b52b824474088e5bb3b6940651660f0e2 (patch)
treea70a225521022a0b7daf34c5812af6da862b8010 /configure.ac
parentBuild: Update m4/ax_pthread.m4 from Autoconf Archive. (diff)
downloadxz-986d8c9b52b824474088e5bb3b6940651660f0e2.tar.xz
Build: Workaround a POSIX shell detection problem on Solaris.
I don't know if the problem is in gnulib's gl_POSIX_SHELL macro or if xzgrep does something that isn't in POSIX. The workaround adds a special case for Solaris: if /usr/xpg4/bin/sh exists and gl_cv_posix_shell wasn't overriden on the configure command line, use that shell for xzgrep and other scripts. That shell is known to work and exists on most Solaris systems.
Diffstat (limited to '')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d14fa40d..c8f76e43 100644
--- a/configure.ac
+++ b/configure.ac
@@ -547,6 +547,16 @@ AC_SUBST([enable_path_for_scripts])
###############################################################################
echo
+case $host_os in
+ solaris*)
+ # The gnulib POSIX shell macro below may pick a shell that
+ # doesn't work with xzgrep. Workaround by picking a shell
+ # that is known to work.
+ if test -z "$gl_cv_posix_shell" && test -x /usr/xpg4/bin/sh; then
+ gl_cv_posix_shell=/usr/xpg4/bin/sh
+ fi
+ ;;
+esac
gl_POSIX_SHELL
if test -z "$POSIX_SHELL" && test "x$enable_scripts" = xyes ; then
AC_MSG_ERROR([No POSIX conforming shell (sh) was found.])