aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2022-10-25 23:28:34 +0300
committerLasse Collin <lasse.collin@tukaani.org>2022-10-25 23:28:34 +0300
commit59c4d6e1390f6f4176f43ac1dad1f7ac03c449b8 (patch)
treed4be04d1c1ea222e8acb811899300f2cad3fb7e0 /configure.ac
parentxz: Fix --single-stream with an empty .xz Stream. (diff)
downloadxz-59c4d6e1390f6f4176f43ac1dad1f7ac03c449b8.tar.xz
Build: Add configure option --disable-microlzma.
MicroLZMA was made for EROFS and used by erofs-utils. It might be used by something else in the future but those wanting a smaller build for specific situations can now disable this rarely-needed feature.
Diffstat (limited to '')
-rw-r--r--configure.ac22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 81739979..170f48ec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -294,6 +294,28 @@ else
fi
+#############
+# MicroLZMA #
+#############
+
+AC_MSG_CHECKING([if MicroLZMA support should be built])
+AC_ARG_ENABLE([microlzma], AS_HELP_STRING([--disable-microlzma],
+ [Do not build MicroLZMA encoder and decoder.
+ It is needed by specific applications only,
+ for example, erofs-utils.]),
+ [], [enable_microlzma=yes])
+case $enable_microlzma in
+ yes | no)
+ AC_MSG_RESULT([$enable_microlzma])
+ ;;
+ *)
+ AC_MSG_RESULT([])
+ AC_MSG_ERROR([--enable-microlzma accepts only `yes' or `no'.])
+ ;;
+esac
+AM_CONDITIONAL(COND_MICROLZMA, test "x$enable_microlzma" = xyes)
+
+
###########################
# Assembler optimizations #
###########################