aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2011-05-28 19:24:56 +0300
committerLasse Collin <lasse.collin@tukaani.org>2011-05-28 19:24:56 +0300
commit492c86345551a51a29bf18e55fe55a5e86f169ce (patch)
tree3b9d66a9579832ff31fc9e2a3e9732fd0817b239 /configure.ac
parentDon't call close(-1) in tuklib_open_stdxxx() on error. (diff)
downloadxz-492c86345551a51a29bf18e55fe55a5e86f169ce.tar.xz
Build: Make configure print if symbol versioning is enabled or not.
Diffstat (limited to '')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 106c0811..5247c979 100644
--- a/configure.ac
+++ b/configure.ac
@@ -407,6 +407,7 @@ AM_CONDITIONAL([COND_SCRIPTS], [test x$enable_scripts != xno])
# Symbol versioning #
#####################
+AC_MSG_CHECKING([if library symbol versioning should be used])
AC_ARG_ENABLE([symbol-versions], [AC_HELP_STRING([--enable-symbol-versions],
[Use symbol versioning for liblzma. Enabled by default on
GNU/Linux, other GNU-based systems, and FreeBSD.])],
@@ -421,6 +422,7 @@ if test "x$enable_symbol_versions" = xauto; then
;;
esac
fi
+AC_MSG_RESULT([$enable_symbol_versions])
AM_CONDITIONAL([COND_SYMVERS], [test "x$enable_symbol_versions" = xyes])