aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2009-09-11 10:24:09 +0300
committerLasse Collin <lasse.collin@tukaani.org>2009-09-11 10:24:09 +0300
commit221be761f467da76875247bc02d7a1716682075d (patch)
tree9dd0da03430086b0306582bc7a230e44c065eb15 /configure.ac
parentFix a couple of warnings. (diff)
downloadxz-221be761f467da76875247bc02d7a1716682075d.tar.xz
Use $(LN_EXEEXT) in symlinks to executables.
This fixes "make install" on operating systems using a suffix for executables. Cygwin is treated specially. The symlink names won't have .exe suffix even though the executables themselves have. Thanks to Charles Wilson.
Diffstat (limited to '')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d125a693..555f5f7c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -44,6 +44,15 @@ case $host_os in
esac
AM_CONDITIONAL([COND_W32], [test "$is_w32" = yes])
+# We need to use $EXEEXT with $(LN_S) when creating symlinks to
+# executables. Cygwin is an exception to this, since it is recommended
+# that symlinks don't have the .exe suffix. To make this work, we
+# define LN_EXEEXT.
+case $host_os in
+ cygwin) LN_EXEEXT= ;;
+ *) LN_EXEEXT='$(EXEEXT)' ;;
+esac
+AC_SUBST([LN_EXEEXT])
echo
echo "Configure options:"