aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2016-06-30 20:27:36 +0300
committerLasse Collin <lasse.collin@tukaani.org>2016-06-30 21:00:49 +0300
commit51baf684376903dbeddd840582bfdf9fa91b311b (patch)
tree7b8287bdc388876ba9cbfabd9b4d2e9f84ab8544 /configure.ac
parentxz: Silence warnings from -Wlogical-op. (diff)
downloadxz-51baf684376903dbeddd840582bfdf9fa91b311b.tar.xz
xz: Fix copying of timestamps on Windows.
xz used to call utime() on Windows, but its result gets lost on close(). Using _futime() seems to work. Thanks to Martok for reporting the bug: http://www.mail-archive.com/xz-devel@tukaani.org/msg00261.html
Diffstat (limited to '')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b8fcf1ef..46e51607 100644
--- a/configure.ac
+++ b/configure.ac
@@ -648,7 +648,7 @@ AC_C_BIGENDIAN
gl_GETOPT
# Find the best function to set timestamps.
-AC_CHECK_FUNCS([futimens futimes futimesat utimes utime], [break])
+AC_CHECK_FUNCS([futimens futimes futimesat utimes _futime utime], [break])
# This is nice to have but not mandatory.
AC_CHECK_FUNCS([posix_fadvise])