aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJia Tan <jiat0218@gmail.com>2023-10-14 12:17:57 +0800
committerJia Tan <jiat0218@gmail.com>2023-10-18 23:54:36 +0800
commit8c0f9376f58c0696d5d6719705164d35542dd891 (patch)
tree104f3471d2ecd77b25314e67fdef743fcecbe193 /configure.ac
parentliblzma: Define CRC_USE_IFUNC in crc_common.h. (diff)
downloadxz-8c0f9376f58c0696d5d6719705164d35542dd891.tar.xz
liblzma: Create crc_clmul.c.
Both crc32_clmul() and crc64_clmul() are now exported from crc32_clmul.c as lzma_crc32_clmul() and lzma_crc64_clmul(). This ensures that is_clmul_supported() (now lzma_is_clmul_supported()) is not duplicated between crc32_fast.c and crc64_fast.c. Also, it encapsulates the complexity of the CLMUL implementations into a single file and reduces the complexity of crc32_fast.c and crc64_fast.c. Before, CLMUL code was present in crc32_fast.c, crc64_fast.c, and crc_common.h. During the conversion, various cleanups were applied to code (thanks to Lasse Collin) including: - Require using semicolons with MASK_/L/H/LH macros. - Variable typing and const handling improvements. - Improvements to comments. - Fixes to the pragmas used. - Removed unneeded variables. - Whitespace improvements. - Fixed CRC_USE_GENERIC_FOR_SMALL_INPUTS handling. - Silenced warnings and removed the need for some #pragmas
Diffstat (limited to '')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4d298430..19dbf1d7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1035,11 +1035,13 @@ __m128i my_clmul(__m128i a)
[Define to 1 if _mm_set_epi64x and
_mm_clmulepi64_si128 are usable.
See configure.ac for details.])
- AC_MSG_RESULT([yes])
+ enable_clmul_crc=yes
], [
- AC_MSG_RESULT([no])
+ enable_clmul_crc=no
])
+ AC_MSG_RESULT([$enable_clmul_crc])
])
+AM_CONDITIONAL([COND_CRC_CLMUL], [test "x$enable_clmul_crc" = xyes])
# Check for sandbox support. If one is found, set enable_sandbox=found.
AS_CASE([$enable_sandbox],