aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJia Tan <jiat0218@gmail.com>2023-03-16 21:35:55 +0800
committerJia Tan <jiat0218@gmail.com>2023-03-17 20:18:41 +0800
commit8fc712fcf41d821069c670f22b8bf628e7a4a877 (patch)
tree0343eb77089fb7882bc241ebfcb487cf182953de /Makefile.am
parentBuild: Install Doxygen docs and include in distribution if generated. (diff)
downloadxz-8fc712fcf41d821069c670f22b8bf628e7a4a877.tar.xz
Build: Create doxygen/update-doxygen script.
This is a helper script to generate the Doxygen documentation. It can be run in 'liblzma' or 'internal' mode by setting the first argument. It will default to 'liblzma' mode and only generate documentation for the liblzma API header files. The helper script will be run during the custom mydist hook when we create releases. This hook already alters the source directory, so its fine to do it here too. This way, we can include the Doxygen generated files in the distrubtion and when installing. In 'liblzma' mode, the JavaScript is stripped from the .html files and the .js files are removed. This avoids license hassle from jQuery and other libraries that Doxygen 1.9.6 puts into jquery.js in minified form.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0df658fd..6d52e0f0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -124,6 +124,7 @@ dist-hook:
mydist:
sh "$(srcdir)/src/liblzma/validate_map.sh"
cd "$(srcdir)/po4a" && sh update-po
+ cd "$(srcdir)/doxygen" && sh update-doxygen
VERSION=$(VERSION); \
if test -d "$(srcdir)/.git" && type git > /dev/null 2>&1; then \
SNAPSHOT=`cd "$(srcdir)" && git describe --abbrev=4 | cut -b2-`; \