aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJia Tan <jiat0218@gmail.com>2024-02-23 20:57:59 +0800
committerJia Tan <jiat0218@gmail.com>2024-02-23 20:57:59 +0800
commitadaacafde6661496ca2814b1e94a3ba5186428cb (patch)
tree28164457659dbff02a9312f9746f5d76ac2add41 /CMakeLists.txt
parentxz: Fix Capsicum sandbox compile error. (diff)
downloadxz-adaacafde6661496ca2814b1e94a3ba5186428cb.tar.xz
Build: Define HAVE_MICROLZMA when it is configured.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 06282b4d..4924f436 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -819,6 +819,10 @@ if(MICROLZMA_DECODER)
target_sources(liblzma PRIVATE src/liblzma/common/microlzma_decoder.c)
endif()
+if (MICROLZMA_ENCODER OR MICROLZMA_DECODER)
+ add_compile_definitions(HAVE_MICROLZMA)
+endif()
+
#############################
# lzip (.lz) format support #