aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJia Tan <jiat0218@gmail.com>2022-12-29 00:25:18 +0800
committerLasse Collin <lasse.collin@tukaani.org>2023-01-09 16:56:07 +0200
commitbad44cfe19e8be8ae76755369be2a34abcd2b4fa (patch)
treebaaf52721a2e182dcfc4aeba1b02d4b528163608 /CMakeLists.txt
parentliblzma: Remove common.h include from common/index.h. (diff)
downloadxz-bad44cfe19e8be8ae76755369be2a34abcd2b4fa.tar.xz
Tests: Creates test_index_hash.c
Tests all API functions exported from index_hash.h. Does not have a dedicated test for lzma_index_hash_end. [Minor edits were made by Lasse Collin.]
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c4f10594..3a58d740 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -801,6 +801,7 @@ if(BUILD_TESTING)
test_filter_flags
test_hardware
test_index
+ test_index_hash
test_memlimit
test_stream_flags
test_vli
@@ -812,6 +813,7 @@ if(BUILD_TESTING)
target_include_directories("${TEST}" PRIVATE
src/common
src/liblzma/api
+ src/liblzma
lib
)