aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2020-12-16 18:30:14 +0200
committerLasse Collin <lasse.collin@tukaani.org>2022-07-12 18:30:56 +0300
commit880596e4b8731b24f6c19cb737ed7d06fe92dda2 (patch)
treec963e213d22be4298742976371008e0c88de8bc4 /CMakeLists.txt
parentUpdate THANKS. (diff)
downloadxz-880596e4b8731b24f6c19cb737ed7d06fe92dda2.tar.xz
Build: Don't build bundles on Apple OSes.
Thanks to Daniel Packard.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e6ac6832..ffb41943 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -70,6 +70,9 @@ string(REGEX REPLACE
# Among other things, this gives us variables xz_VERSION and xz_VERSION_MAJOR.
project(xz VERSION "${XZ_VERSION}" LANGUAGES C)
+# On Apple OSes, don't build executables as bundles:
+set(CMAKE_MACOSX_BUNDLE OFF)
+
# Definitions common to all targets:
add_compile_definitions(
# Package info: