aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJia Tan <jiat0218@gmail.com>2024-01-22 20:54:56 +0800
committerJia Tan <jiat0218@gmail.com>2024-02-01 20:09:11 +0800
commit761f5b69a4c778c8bcb09279b845b07c28790575 (patch)
tree10bfb5cd27861f5e062567532ec76246e06bd4b5 /CMakeLists.txt
parentliblzma: Refactor crc_common.h. (diff)
downloadxz-761f5b69a4c778c8bcb09279b845b07c28790575.tar.xz
liblzma: Rename crc32_aarch64.h to crc32_arm64.h.
Even though the proper name for the architecture is aarch64, this project uses ARM64 throughout. So the rename is for consistency. Additionally, crc32_arm64.h was slightly refactored for the following changes: * Added MSVC, FreeBSD, and macOS support in is_arch_extension_supported(). * crc32_arch_optimized() now checks the size when aligning the buffer. * crc32_arch_optimized() loop conditions were slightly modified to avoid both decrementing the size and incrementing the buffer pointer. * Use the intrinsic wrappers defined in <arm_acle.h> because GCC and Clang name them differently. * Minor spacing and comment changes.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b21090f7..408b1605 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -230,7 +230,7 @@ add_library(liblzma
src/liblzma/check/check.h
src/liblzma/check/crc_common.h
src/liblzma/check/crc_x86_clmul.h
- src/liblzma/check/crc32_aarch64.h
+ src/liblzma/check/crc32_arm64.h
src/liblzma/common/block_util.c
src/liblzma/common/common.c
src/liblzma/common/common.h