aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2023-09-21 20:42:52 +0300
committerLasse Collin <lasse.collin@tukaani.org>2023-09-22 20:10:10 +0300
commit01311b81f03cce1c0ce847a3d556f84dbd439343 (patch)
tree71d557e9d1ec0ff04b57a32266d96211d4005db2 /CMakeLists.txt
parentCMake: Add a comment about threads on Cygwin. (diff)
downloadxz-01311b81f03cce1c0ce847a3d556f84dbd439343.tar.xz
CMake: Wrap two overlong lines that are possible to wrap.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 246d11a1..ac04ff6e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -389,9 +389,11 @@ if(ENABLE_THREADS)
target_link_libraries(liblzma Threads::Threads)
add_compile_definitions(MYTHREAD_POSIX)
- # Check if pthread_condattr_setclock() exists to use CLOCK_MONOTONIC.
+ # Check if pthread_condattr_setclock() exists to
+ # use CLOCK_MONOTONIC.
if(HAVE_CLOCK_MONOTONIC)
- list(INSERT CMAKE_REQUIRED_LIBRARIES 0 "${CMAKE_THREAD_LIBS_INIT}")
+ list(INSERT CMAKE_REQUIRED_LIBRARIES 0
+ "${CMAKE_THREAD_LIBS_INIT}")
check_symbol_exists(pthread_condattr_setclock pthread.h
HAVE_PTHREAD_CONDATTR_SETCLOCK)
tuklib_add_definition_if(ALL HAVE_PTHREAD_CONDATTR_SETCLOCK)