aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2023-06-27 17:19:49 +0300
committerJia Tan <jiat0218@gmail.com>2023-06-27 23:56:06 +0800
commit23fb9e3a329117c2968c1e7388b6ef07c782dba1 (patch)
treed4dfce2d1913f45bcb8ef76762b1a8f83cbe96c8 /CMakeLists.txt
parentliblzma: Add ifunc implementation to crc64_fast.c. (diff)
downloadxz-23fb9e3a329117c2968c1e7388b6ef07c782dba1.tar.xz
CMake: Rename CHECK_ATTR_IFUNC to ALLOW_ATTR_IFUNC.
It's so that there's a clear difference in wording compared to liblzma's integrity check types.
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fb5d2582..66a5ded6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -764,10 +764,10 @@ cmake_pop_check_state()
tuklib_add_definition_if(liblzma HAVE_FUNC_ATTRIBUTE_CONSTRUCTOR)
# Check for __attribute__((__ifunc__())) support.
-option(CHECK_ATTR_IFUNC "Use __attribute__((__ifunc__())) if supported by \
-the system" ON)
+option(ALLOW_ATTR_IFUNC "Allow use of __attribute__((__ifunc__())) if \
+supported by the system" ON)
-if (CHECK_ATTR_IFUNC)
+if(ALLOW_ATTR_IFUNC)
cmake_push_check_state()
set(CMAKE_REQUIRED_FLAGS "-Werror")
check_c_source_compiles("