aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2023-09-21 19:17:40 +0300
committerLasse Collin <lasse.collin@tukaani.org>2023-09-22 20:10:10 +0300
commitedd563daf0da1d00018684614803c77ab62efcd6 (patch)
tree33e0e09971efb2ab0775212caf8c2f9c183893df /CMakeLists.txt
parentCMake: Allow building xz with Visual Studio 2015 and later. (diff)
downloadxz-edd563daf0da1d00018684614803c77ab62efcd6.tar.xz
CMake: Require VS2015 or later for building xzdec.
xzdec might build with VS2013 but it hasn't been tested. It was never supported before and VS2013 is old anyway so for simplicity only liblzma is supported with VS2013.
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d2fe35df..13ff7b1c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1035,7 +1035,7 @@ endif()
# xzdec
#############################################################################
-if(HAVE_DECODERS)
+if(HAVE_DECODERS AND (NOT MSVC OR MSVC_VERSION GREATER_EQUAL 1900))
add_executable(xzdec
src/common/sysdefs.h
src/common/tuklib_common.h