aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2020-12-16 18:30:14 +0200
committerLasse Collin <lasse.collin@tukaani.org>2020-12-16 18:30:14 +0200
commit21588ca34af98738954fc12ded1b89d7294ef646 (patch)
tree133293ead6b5685570eb935bf4a1de42aa90698b /CMakeLists.txt
parentUpdate THANKS. (diff)
downloadxz-21588ca34af98738954fc12ded1b89d7294ef646.tar.xz
Build: Don't build bundles on Apple OSes.
Thanks to Daniel Packard.
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c21ab567..5fe769b9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -70,6 +70,9 @@ string(REGEX REPLACE
# Among other things, this gives us variables xz_VERSION and xz_VERSION_MAJOR.
project(xz VERSION "${XZ_VERSION}" LANGUAGES C)
+# On Apple OSes, don't build executables as bundles:
+set(CMAKE_MACOSX_BUNDLE OFF)
+
# Definitions common to all targets:
add_compile_definitions(
# Package info: