aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2023-01-09 11:27:24 +0200
committerLasse Collin <lasse.collin@tukaani.org>2023-01-09 16:58:27 +0200
commit3d45987451b1c3bb42697b29341824c0e5484cba (patch)
treebd0d021fa1603728d99d70b50caf33347a3e8d8e /CMakeLists.txt
parentCMake/Windows: Add resource files to xz.exe and xzdec.exe. (diff)
downloadxz-3d45987451b1c3bb42697b29341824c0e5484cba.tar.xz
CMake: Fix a copypaste error in xzdec Windows resource file handling.
It was my mistake. Thanks to Iouri Kharon for the bug report.
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 33d58a6f..7d7a9d86 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -613,8 +613,8 @@ if(HAVE_GETOPT_LONG)
if(WIN32)
# Add the Windows resource file for xzdec.exe.
- target_sources(xz PRIVATE src/xzdec/xzdec_w32res.rc)
- set_target_properties(xz PROPERTIES
+ target_sources(xzdec PRIVATE src/xzdec/xzdec_w32res.rc)
+ set_target_properties(xzdec PROPERTIES
LINK_DEPENDS "${CMAKE_CURRENT_SOURCE_DIR}/src/common/common_w32res.rc"
)
endif()