aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 844778f..6b01f37 100644
--- a/configure.ac
+++ b/configure.ac
@@ -466,7 +466,7 @@ fi
dnl
dnl Check for dlopen -- first try libc then libdl.
dnl
-if test "$PLUGINS" = "yes"; then
+if test "$PLUGINS" = "yes" || test "$PKCS11" = "yes"; then
AC_CHECKING([for libdl Library and Header files])
AC_CHECK_HEADER(dlfcn.h,
[AC_CHECK_FUNC(dlopen,
@@ -603,7 +603,7 @@ fi
dnl enable pkcs11 capability
if test "$PKCS11" = "yes"; then
- AC_DEFINE(ENABLE_PKCS11, 1, [Enable PKCS#11 capability])
+ AC_DEFINE(USE_PKCS11, 1, [Enable PKCS11 capability])
fi
dnl enable socks