aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configure.ac22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c6d19f9..ae40458 100644
--- a/configure.ac
+++ b/configure.ac
@@ -170,6 +170,18 @@ AC_ARG_ENABLE(iproute2,
test $enableval = "yes" && AC_DEFINE(CONFIG_FEATURE_IPROUTE, 1, [enable iproute2 support])
)
+AC_ARG_ENABLE(def-auth,
+ [ --disable-def-auth Disable deferred authentication],
+ [DEF_AUTH="$enableval"],
+ [DEF_AUTH="yes"]
+)
+
+AC_ARG_ENABLE(pf,
+ [ --disable-pf Disable internal packet filter],
+ [PF="$enableval"],
+ [PF="yes"]
+)
+
AC_ARG_ENABLE(strict,
[ --enable-strict Enable strict compiler warnings (debugging option)],
[STRICT="$enableval"],
@@ -816,6 +828,16 @@ if test "$PORT_SHARE" = "yes"; then
AC_DEFINE(ENABLE_PORT_SHARE, 1, [Enable TCP Server port sharing])
fi
+dnl enable deferred auth
+if test "$DEF_AUTH" = "yes"; then
+ AC_DEFINE(CONFIGURE_DEF_AUTH, 1, [Enable deferred authentication])
+fi
+
+dnl enable internal packet filter
+if test "$PF" = "yes"; then
+ AC_DEFINE(CONFIGURE_PF, 1, [Enable internal packet filter])
+fi
+
dnl enable strict compiler warnings
if test "$STRICT" = "yes"; then
CFLAGS="$CFLAGS -Wall -Wno-unused-parameter -Wno-unused-function"