aboutsummaryrefslogtreecommitdiff
path: root/tests/fuzz/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/fuzz/CMakeLists.txt')
-rw-r--r--tests/fuzz/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/fuzz/CMakeLists.txt b/tests/fuzz/CMakeLists.txt
index 01c17359c..5b1cef182 100644
--- a/tests/fuzz/CMakeLists.txt
+++ b/tests/fuzz/CMakeLists.txt
@@ -113,3 +113,15 @@ set_property(TARGET load-from-json_fuzz_tests
PROPERTY
FOLDER "tests")
+add_executable(base58_fuzz_tests base58.cpp fuzzer.cpp)
+target_link_libraries(base58_fuzz_tests
+ PRIVATE
+ common
+ epee
+ ${Boost_PROGRAM_OPTIONS_LIBRARY}
+ ${CMAKE_THREAD_LIBS_INIT}
+ ${EXTRA_LIBRARIES})
+set_property(TARGET base58_fuzz_tests
+ PROPERTY
+ FOLDER "tests")
+