aboutsummaryrefslogtreecommitdiff
path: root/src/wallet/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/wallet/CMakeLists.txt')
-rw-r--r--src/wallet/CMakeLists.txt54
1 files changed, 1 insertions, 53 deletions
diff --git a/src/wallet/CMakeLists.txt b/src/wallet/CMakeLists.txt
index bf238ae37..2dd64a38f 100644
--- a/src/wallet/CMakeLists.txt
+++ b/src/wallet/CMakeLists.txt
@@ -40,18 +40,7 @@ set(wallet_sources
wallet_rpc_payments.cpp
)
-set(wallet_private_headers
- wallet2.h
- wallet_args.h
- wallet_errors.h
- wallet_rpc_server.h
- wallet_rpc_server_commands_defs.h
- wallet_rpc_server_error_codes.h
- ringdb.h
- node_rpc_proxy.h
- message_store.h
- message_transporter.h
- wallet_rpc_helpers.h)
+monero_find_all_headers(wallet_private_headers "${CMAKE_CURRENT_SOURCE_DIR}")
monero_private_headers(wallet
${wallet_private_headers})
@@ -115,45 +104,4 @@ if(NOT IOS)
install(TARGETS wallet_rpc_server DESTINATION bin)
endif()
-# build and install libwallet_merged only if we building for GUI
-if (BUILD_GUI_DEPS)
- set(libs_to_merge
- wallet_api
- wallet
- rpc_base
- multisig
- blockchain_db
- cryptonote_core
- cryptonote_basic
- mnemonics
- common
- cncrypto
- device
- hardforks
- ringct
- ringct_basic
- checkpoints
- version
- net
- device_trezor)
-
- foreach(lib ${libs_to_merge})
- list(APPEND objlibs $<TARGET_OBJECTS:obj_${lib}>) # matches naming convention in src/CMakeLists.txt
- endforeach()
- add_library(wallet_merged STATIC ${objlibs})
- if(IOS)
- set(lib_folder lib-${ARCH})
- else()
- set(lib_folder lib)
- endif()
- install(TARGETS wallet_merged
- ARCHIVE DESTINATION ${lib_folder})
-
- install(FILES ${TREZOR_DEP_LIBS}
- DESTINATION ${lib_folder})
- file(WRITE "trezor_link_flags.txt" ${TREZOR_DEP_LINKER})
- install(FILES "trezor_link_flags.txt"
- DESTINATION ${lib_folder})
-endif()
-
add_subdirectory(api)