aboutsummaryrefslogtreecommitdiff
path: root/src/wallet/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/wallet/CMakeLists.txt')
-rw-r--r--src/wallet/CMakeLists.txt15
1 files changed, 14 insertions, 1 deletions
diff --git a/src/wallet/CMakeLists.txt b/src/wallet/CMakeLists.txt
index fe87d0de1..24399790c 100644
--- a/src/wallet/CMakeLists.txt
+++ b/src/wallet/CMakeLists.txt
@@ -41,6 +41,8 @@ set(wallet_sources
api/pending_transaction.cpp
api/utils.cpp
api/address_book.cpp
+ api/subaddress.cpp
+ api/subaddress_account.cpp
api/unsigned_transaction.cpp)
set(wallet_api_headers
@@ -62,6 +64,8 @@ set(wallet_private_headers
api/pending_transaction.h
api/common_defines.h
api/address_book.h
+ api/subaddress.h
+ api/subaddress_account.h
api/unsigned_transaction.h)
monero_private_headers(wallet
@@ -125,7 +129,16 @@ endif()
# build and install libwallet_merged only if we building for GUI
if (BUILD_GUI_DEPS)
- set(libs_to_merge wallet cryptonote_core cryptonote_basic mnemonics common cncrypto ringct)
+ set(libs_to_merge
+ wallet
+ cryptonote_core
+ cryptonote_basic
+ mnemonics
+ common
+ cncrypto
+ ringct
+ checkpoints
+ version)
foreach(lib ${libs_to_merge})
list(APPEND objlibs $<TARGET_OBJECTS:obj_${lib}>) # matches naming convention in src/CMakeLists.txt