aboutsummaryrefslogtreecommitdiff
path: root/src/wallet/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/wallet/CMakeLists.txt')
-rw-r--r--src/wallet/CMakeLists.txt22
1 files changed, 13 insertions, 9 deletions
diff --git a/src/wallet/CMakeLists.txt b/src/wallet/CMakeLists.txt
index 40c5d38ae..96653556b 100644
--- a/src/wallet/CMakeLists.txt
+++ b/src/wallet/CMakeLists.txt
@@ -74,14 +74,18 @@ target_link_libraries(wallet
${Boost_REGEX_LIBRARY}
${EXTRA_LIBRARIES})
-set(libs_to_merge wallet cryptonote_core mnemonics common crypto ringct)
-foreach(lib ${libs_to_merge})
- list(APPEND objlibs $<TARGET_OBJECTS:obj_${lib}>) # matches naming convention in src/CMakeLists.txtA
-endforeach()
-add_library(wallet_merged STATIC ${objlibs})
-install(TARGETS wallet_merged
- ARCHIVE DESTINATION lib)
+# build and install libwallet_merged only if we building for GUI
+if (BUILD_GUI_DEPS)
+ set(libs_to_merge wallet cryptonote_core mnemonics common crypto ringct)
-install(FILES ${wallet_api_headers}
- DESTINATION include/wallet)
+ foreach(lib ${libs_to_merge})
+ list(APPEND objlibs $<TARGET_OBJECTS:obj_${lib}>) # matches naming convention in src/CMakeLists.txt
+ endforeach()
+ add_library(wallet_merged STATIC ${objlibs})
+ install(TARGETS wallet_merged
+ ARCHIVE DESTINATION lib)
+
+ install(FILES ${wallet_api_headers}
+ DESTINATION include/wallet)
+endif()