aboutsummaryrefslogtreecommitdiff
path: root/src/wallet/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/wallet/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/wallet/CMakeLists.txt b/src/wallet/CMakeLists.txt
index 0b8fe4cb1..7ed1004e2 100644
--- a/src/wallet/CMakeLists.txt
+++ b/src/wallet/CMakeLists.txt
@@ -76,11 +76,15 @@ target_link_libraries(wallet
${EXTRA_LIBRARIES})
-set(libs_to_merge wallet cryptonote_core mnemonics common crypto)
+# set(libs_to_merge wallet cryptonote_core mnemonics common crypto ${UNBOUND_LIBRARY} )
+set(libs_to_merge wallet cryptonote_core mnemonics common crypto)
#MERGE_STATIC_LIBS(wallet_merged wallet_merged "${libs_to_merge}")
merge_static_libs(wallet_merged "${libs_to_merge}")
-install(TARGETS wallet_merged
+# hack - repack libunbound into another static lib - there's conflicting object file "random.c.obj"
+merge_static_libs(wallet_merged2 "${UNBOUND_LIBRARY}")
+
+install(TARGETS wallet_merged wallet_merged2
ARCHIVE DESTINATION lib)
install(FILES ${wallet_api_headers}