aboutsummaryrefslogtreecommitdiff
path: root/src/rpc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/rpc/CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/src/rpc/CMakeLists.txt b/src/rpc/CMakeLists.txt
index 6e90d1a91..1716da75b 100644
--- a/src/rpc/CMakeLists.txt
+++ b/src/rpc/CMakeLists.txt
@@ -43,13 +43,11 @@ bitmonero_add_library(rpc
${rpc_headers}
${rpc_private_headers})
target_link_libraries(rpc
- LINK_PRIVATE
+ PUBLIC
cryptonote_core
cryptonote_protocol
- ${Boost_CHRONO_LIBRARY}
- ${Boost_REGEX_LIBRARY}
- ${Boost_SYSTEM_LIBRARY}
${Boost_THREAD_LIBRARY}
+ PRIVATE
${EXTRA_LIBRARIES})
add_dependencies(rpc
version)