aboutsummaryrefslogtreecommitdiff
path: root/src/miner/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/miner/CMakeLists.txt')
-rw-r--r--src/miner/CMakeLists.txt56
1 files changed, 0 insertions, 56 deletions
diff --git a/src/miner/CMakeLists.txt b/src/miner/CMakeLists.txt
deleted file mode 100644
index d065b9950..000000000
--- a/src/miner/CMakeLists.txt
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright (c) 2014-2016, The Monero Project
-#
-# All rights reserved.
-#
-# Redistribution and use in source and binary forms, with or without modification, are
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of source code must retain the above copyright notice, this list of
-# conditions and the following disclaimer.
-#
-# 2. Redistributions in binary form must reproduce the above copyright notice, this list
-# of conditions and the following disclaimer in the documentation and/or other
-# materials provided with the distribution.
-#
-# 3. Neither the name of the copyright holder nor the names of its contributors may be
-# used to endorse or promote products derived from this software without specific
-# prior written permission.
-#
-# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY
-# EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL
-# THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
-# INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
-# STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF
-# THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-set(simpleminer_sources
- simpleminer.cpp)
-
-set(simpleminer_headers)
-
-set(simpleminer_private_headers
- simpleminer.h
- simpleminer_protocol_defs.h
- target_helper.h)
-
-bitmonero_private_headers(simpleminer
- ${simpleminer_private_headers})
-bitmonero_add_executable(simpleminer
- ${simpleminer_sources}
- ${simpleminer_headers}
- ${simpleminer_private_headers})
-target_link_libraries(simpleminer
- LINK_PRIVATE
- cryptonote_core
- common
- ${Boost_FILESYSTEM_LIBRARY}
- ${Boost_PROGRAM_OPTIONS_LIBRARY}
- ${Boost_REGEX_LIBRARY}
- ${Boost_CHRONO_LIBRARY}
- ${Boost_SYSTEM_LIBRARY}
- ${Boost_THREAD_LIBRARY}
- ${CMAKE_THREAD_LIBS_INIT}
- ${EXTRA_LIBRARIES})