aboutsummaryrefslogtreecommitdiff
path: root/src/device/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/device/CMakeLists.txt')
-rw-r--r--src/device/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/device/CMakeLists.txt b/src/device/CMakeLists.txt
index 727134f75..8f446f42a 100644
--- a/src/device/CMakeLists.txt
+++ b/src/device/CMakeLists.txt
@@ -58,6 +58,12 @@ endif()
set(device_private_headers)
+if(PER_BLOCK_CHECKPOINT)
+ set(Blocks "blocks")
+else()
+ set(Blocks "")
+endif()
+
monero_private_headers(device
${device_private_headers})
@@ -73,4 +79,5 @@ target_link_libraries(device
ringct_basic
${OPENSSL_CRYPTO_LIBRARIES}
PRIVATE
+ ${Blocks}
${EXTRA_LIBRARIES})