aboutsummaryrefslogtreecommitdiff
path: root/src/device/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/device/CMakeLists.txt19
1 files changed, 14 insertions, 5 deletions
diff --git a/src/device/CMakeLists.txt b/src/device/CMakeLists.txt
index cc2d20a54..8f446f42a 100644
--- a/src/device/CMakeLists.txt
+++ b/src/device/CMakeLists.txt
@@ -32,18 +32,27 @@ set(device_sources
log.cpp
)
-if(PCSC_FOUND)
- set(device_sources ${device_sources} device_ledger.cpp)
+if(HIDAPI_FOUND)
+ set(device_sources
+ ${device_sources}
+ device_ledger.cpp
+ device_io_hid.cpp
+ )
endif()
set(device_headers
device.hpp
+ device_io.hpp
device_default.hpp
log.hpp
)
-if(PCSC_FOUND)
- set(device_headers ${device_headers} device_ledger.hpp)
+if(HIDAPI_FOUND)
+ set(device_headers
+ ${device_headers}
+ device_ledger.hpp
+ device_io_hid.hpp
+ )
endif()
set(device_private_headers)
@@ -65,7 +74,7 @@ monero_add_library(device
target_link_libraries(device
PUBLIC
- ${PCSC_LIBRARIES}
+ ${HIDAPI_LIBRARIES}
cncrypto
ringct_basic
${OPENSSL_CRYPTO_LIBRARIES}