aboutsummaryrefslogtreecommitdiff
path: root/src/cryptonote_protocol/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/cryptonote_protocol/CMakeLists.txt')
-rw-r--r--src/cryptonote_protocol/CMakeLists.txt14
1 files changed, 4 insertions, 10 deletions
diff --git a/src/cryptonote_protocol/CMakeLists.txt b/src/cryptonote_protocol/CMakeLists.txt
index 0d759e9c4..21925b60e 100644
--- a/src/cryptonote_protocol/CMakeLists.txt
+++ b/src/cryptonote_protocol/CMakeLists.txt
@@ -32,16 +32,10 @@ project (bitmonero CXX)
file(GLOB CRYPTONOTE_PROTOCOL *)
source_group(cryptonote_protocol FILES ${CRYPTONOTE_PROTOCOL})
-#add_library(p2p ${P2P})
-
-#bitmonero_private_headers(p2p ${CRYPTONOTE_PROTOCOL})
+#bitmonero_private_headers(cryptonote_protocol ${CRYPTONOTE_PROTOCOL})
bitmonero_add_library(cryptonote_protocol ${CRYPTONOTE_PROTOCOL})
-#target_link_libraries(p2p)
-# LINK_PRIVATE
-# ${Boost_CHRONO_LIBRARY}
-# ${Boost_REGEX_LIBRARY}
-# ${Boost_SYSTEM_LIBRARY}
-# ${Boost_THREAD_LIBRARY}
-# ${EXTRA_LIBRARIES})
+target_link_libraries(cryptonote_protocol
+ PRIVATE
+ ${EXTRA_LIBRARIES})
add_dependencies(cryptonote_protocol
version)