aboutsummaryrefslogtreecommitdiff
path: root/src/cryptonote_basic/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/cryptonote_basic/CMakeLists.txt')
-rw-r--r--src/cryptonote_basic/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/cryptonote_basic/CMakeLists.txt b/src/cryptonote_basic/CMakeLists.txt
index ec7aa251f..1503b277e 100644
--- a/src/cryptonote_basic/CMakeLists.txt
+++ b/src/cryptonote_basic/CMakeLists.txt
@@ -26,6 +26,12 @@
# STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF
# THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+if(APPLE)
+ find_library(IOKIT_LIBRARY IOKit)
+ mark_as_advanced(IOKIT_LIBRARY)
+ list(APPEND EXTRA_LIBRARIES ${IOKIT_LIBRARY})
+endif()
+
set(cryptonote_basic_sources
account.cpp
checkpoints.cpp