aboutsummaryrefslogtreecommitdiff
path: root/src/crypto/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crypto/CMakeLists.txt')
-rw-r--r--src/crypto/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/crypto/CMakeLists.txt b/src/crypto/CMakeLists.txt
index d22d59b36..3a4d09fd8 100644
--- a/src/crypto/CMakeLists.txt
+++ b/src/crypto/CMakeLists.txt
@@ -49,7 +49,7 @@ set(crypto_sources
CryptonightR_JIT.c
tree-hash.c)
-if(ARCH_ID STREQUAL "i386" OR ARCH_ID STREQUAL "x86_64" OR ARCH_ID STREQUAL "x86-64")
+if(ARCH_ID STREQUAL "i386" OR ARCH_ID STREQUAL "x86_64" OR ARCH_ID STREQUAL "x86-64" OR ARCH_ID STREQUAL "amd64")
list(APPEND crypto_sources CryptonightR_template.S)
endif()