aboutsummaryrefslogtreecommitdiff
path: root/src/crypto/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crypto/CMakeLists.txt')
-rw-r--r--src/crypto/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/crypto/CMakeLists.txt b/src/crypto/CMakeLists.txt
index 3a4d09fd8..80f1e5d7e 100644
--- a/src/crypto/CMakeLists.txt
+++ b/src/crypto/CMakeLists.txt
@@ -46,6 +46,7 @@ set(crypto_sources
random.c
skein.c
slow-hash.c
+ rx-slow-hash.c
CryptonightR_JIT.c
tree-hash.c)
@@ -53,6 +54,8 @@ if(ARCH_ID STREQUAL "i386" OR ARCH_ID STREQUAL "x86_64" OR ARCH_ID STREQUAL "x86
list(APPEND crypto_sources CryptonightR_template.S)
endif()
+include_directories(${RANDOMX_INCLUDE})
+
set(crypto_headers)
set(crypto_private_headers
@@ -86,6 +89,7 @@ monero_add_library(cncrypto
target_link_libraries(cncrypto
PUBLIC
epee
+ randomx
${Boost_SYSTEM_LIBRARY}
${SODIUM_LIBRARY}
PRIVATE