aboutsummaryrefslogtreecommitdiff
path: root/src/blockchain_db/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/blockchain_db/CMakeLists.txt')
-rw-r--r--src/blockchain_db/CMakeLists.txt76
1 files changed, 76 insertions, 0 deletions
diff --git a/src/blockchain_db/CMakeLists.txt b/src/blockchain_db/CMakeLists.txt
new file mode 100644
index 000000000..adbe804aa
--- /dev/null
+++ b/src/blockchain_db/CMakeLists.txt
@@ -0,0 +1,76 @@
+# Copyright (c) 2014-2015, The Monero Project
+#
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without modification, are
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of source code must retain the above copyright notice, this list of
+# conditions and the following disclaimer.
+#
+# 2. Redistributions in binary form must reproduce the above copyright notice, this list
+# of conditions and the following disclaimer in the documentation and/or other
+# materials provided with the distribution.
+#
+# 3. Neither the name of the copyright holder nor the names of its contributors may be
+# used to endorse or promote products derived from this software without specific
+# prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY
+# EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL
+# THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+# INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
+# STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF
+# THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+set(blockchain_db_sources
+ blockchain_db.cpp
+ lmdb/db_lmdb.cpp
+ )
+
+if (NOT STATIC)
+ set(blockchain_db_sources
+ ${blockchain_db_sources}
+ berkeleydb/db_bdb.cpp
+ )
+endif()
+
+
+set(blockchain_db_headers)
+
+set(blockchain_db_private_headers
+ blockchain_db.h
+ lmdb/db_lmdb.h
+ )
+
+if (NOT STATIC)
+ set(blockchain_db_private_headers
+ ${blockchain_db_private_headers}
+ berkeleydb/db_bdb.h
+ )
+endif()
+
+bitmonero_private_headers(blockchain_db
+ ${crypto_private_headers})
+bitmonero_add_library(blockchain_db
+ ${blockchain_db_sources}
+ ${blockchain_db_headers}
+ ${blockchain_db_private_headers})
+target_link_libraries(blockchain_db
+ LINK_PUBLIC
+ common
+ crypto
+ cryptonote_core
+ ${Boost_DATE_TIME_LIBRARY}
+ ${Boost_PROGRAM_OPTIONS_LIBRARY}
+ ${Boost_SERIALIZATION_LIBRARY}
+ ${LMDB_LIBRARY}
+ ${BDB_LIBRARY}
+ LINK_PRIVATE
+ ${Boost_FILESYSTEM_LIBRARY}
+ ${Boost_SYSTEM_LIBRARY}
+ ${Boost_THREAD_LIBRARY}
+ ${EXTRA_LIBRARIES})