aboutsummaryrefslogtreecommitdiff
path: root/external/unbound/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'external/unbound/CMakeLists.txt')
-rw-r--r--external/unbound/CMakeLists.txt16
1 files changed, 8 insertions, 8 deletions
diff --git a/external/unbound/CMakeLists.txt b/external/unbound/CMakeLists.txt
index b00ff9b3c..72e2addd6 100644
--- a/external/unbound/CMakeLists.txt
+++ b/external/unbound/CMakeLists.txt
@@ -132,7 +132,7 @@ set(common_src
set(compat_src)
-foreach (symbol IN ITEMS ctime_r gmtime_r inet_aton inet_ntop inet_pton malloc memcmp memmove snprintf strlcat strlcpy strptime explicit_bzero arc4random arc4random_uniform sha512)
+foreach (symbol IN ITEMS ctime_r gmtime_r inet_aton inet_ntop inet_pton malloc memcmp memmove snprintf strlcat strlcpy strptime explicit_bzero arc4random arc4random_uniform sha512 reallocarray)
string(TOUPPER "${symbol}" upper_sym)
if (NOT HAVE_${upper_sym})
list(APPEND compat_src
@@ -165,13 +165,13 @@ if (NOT HAVE_GETADDRINFO)
endif ()
set(sldns_src
- ldns/keyraw.c
- ldns/sbuffer.c
- ldns/wire2str.c
- ldns/parse.c
- ldns/parseutil.c
- ldns/rrdef.c
- ldns/str2wire.c)
+ sldns/keyraw.c
+ sldns/sbuffer.c
+ sldns/wire2str.c
+ sldns/parse.c
+ sldns/parseutil.c
+ sldns/rrdef.c
+ sldns/str2wire.c)
set(libunbound_src
libunbound/context.c