aboutsummaryrefslogtreecommitdiff
path: root/external/unbound/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'external/unbound/CMakeLists.txt')
-rw-r--r--external/unbound/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/external/unbound/CMakeLists.txt b/external/unbound/CMakeLists.txt
index f17897c6b..fdfa0a0fe 100644
--- a/external/unbound/CMakeLists.txt
+++ b/external/unbound/CMakeLists.txt
@@ -183,3 +183,19 @@ endif ()
set(LIBEVENT2_LIBDIR
"${LIBEVENT2_LIBDIR}"
PARENT_SCOPE)
+
+if (MINGW)
+ # There is no variable for this (probably due to the fact that the pthread
+ # library is implicit with a link in msys).
+ find_library(win32pthread
+ NAMES libwinpthread-1.dll)
+ foreach (input IN LISTS win32pthread OPENSSL_LIBRARIES)
+ # Copy shared libraries into the build tree so that no PATH manipulation is
+ # necessary.
+ get_filename_component(name "${input}" NAME)
+ configure_file(
+ "${input}"
+ "${CMAKE_BINARY_DIR}/bin/${name}"
+ COPYONLY)
+ endforeach ()
+endif ()