aboutsummaryrefslogtreecommitdiff
path: root/external/unbound/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'external/unbound/CMakeLists.txt')
-rw-r--r--external/unbound/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/external/unbound/CMakeLists.txt b/external/unbound/CMakeLists.txt
index 47010e1b3..4edb51230 100644
--- a/external/unbound/CMakeLists.txt
+++ b/external/unbound/CMakeLists.txt
@@ -30,6 +30,15 @@ cmake_minimum_required(VERSION 2.8.7)
project(unbound C)
+if (APPLE)
+ if (NOT OpenSSL_DIR)
+ EXECUTE_PROCESS(COMMAND brew --prefix openssl
+ OUTPUT_VARIABLE OPENSSL_ROOT_DIR
+ OUTPUT_STRIP_TRAILING_WHITESPACE)
+ message(STATUS "Using OpenSSL found at ${OPENSSL_ROOT_DIR}")
+ endif()
+endif()
+
find_package(OpenSSL REQUIRED)
find_package(Threads)
@@ -159,6 +168,11 @@ elseif (WIN32)
compat/getentropy_win.c)
endif ()
+if (NOT HAVE_ISBLANK)
+ list(APPEND compat_src
+ compat/isblank.c)
+endif ()
+
if (NOT HAVE_GETADDRINFO)
list(APPEND compat_src
compat/fake-rfc2553.c)