aboutsummaryrefslogtreecommitdiff
path: root/external/miniupnpc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'external/miniupnpc/CMakeLists.txt')
-rw-r--r--[-rwxr-xr-x]external/miniupnpc/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/external/miniupnpc/CMakeLists.txt b/external/miniupnpc/CMakeLists.txt
index 74aaa0509..5e4a90bbf 100755..100644
--- a/external/miniupnpc/CMakeLists.txt
+++ b/external/miniupnpc/CMakeLists.txt
@@ -36,7 +36,7 @@ else (NOT WIN32)
endif (NOT WIN32)
if (CMAKE_SYSTEM_NAME STREQUAL "Darwin")
- add_definitions (-DMACOSX -D_DARWIN_C_SOURCE)
+ add_definitions (-D_DARWIN_C_SOURCE)
endif ()
# Set compiler specific build flags
@@ -86,7 +86,7 @@ endif (NOT WIN32 AND NOT CMAKE_SYSTEM_NAME STREQUAL "AmigaOS")
if (WIN32)
set_source_files_properties (${MINIUPNPC_SOURCES} PROPERTIES
- COMPILE_DEFINITIONS STATICLIB
+ COMPILE_DEFINITIONS MINIUPNP_STATICLIB
COMPILE_DEFINITIONS MINIUPNP_EXPORTS
)
endif (WIN32)
@@ -167,6 +167,8 @@ install (FILES
igd_desc_parse.h
upnpreplyparse.h
upnperrors.h
+ miniupnpctypes.h
+ portlistingparse.h
declspec.h
DESTINATION include/miniupnpc
)