aboutsummaryrefslogtreecommitdiff
path: root/external/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'external/CMakeLists.txt')
-rwxr-xr-xexternal/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/external/CMakeLists.txt b/external/CMakeLists.txt
index 83e9e6dee..b1fa8b2ff 100755
--- a/external/CMakeLists.txt
+++ b/external/CMakeLists.txt
@@ -89,14 +89,14 @@ IF(!UNBOUND_INCLUDE_DIR OR STATIC)
FIND_PACKAGE(OpenSSL QUIET)
IF(!OPENSSL_LIBRARIES)
- MESSAGE(FATAL_ERROR "${BoldRed}Could not find the openssl library. Please make sure you have installed openssl or libssl-dev or the equivalent${ColourReset}")
+ die("Could not find the openssl library. Please make sure you have installed openssl or libssl-dev or the equivalent")
ELSE()
MESSAGE(STATUS "Found openssl libraries")
ENDIF()
FIND_PACKAGE(Expat QUIET)
IF(!EXPAT_LIBRARIES)
- MESSAGE(FATAL_ERROR "${BoldRed}Could not find the expat library. Please make sure you have installed libexpat or libexpat-dev or the equivalent${ColourReset}")
+ die("Could not find the expat library. Please make sure you have installed libexpat or libexpat-dev or the equivalent")
ELSE()
MESSAGE(STATUS "Found expat libraries")
ENDIF()
@@ -170,6 +170,6 @@ ELSE()
set(UNBOUND_INCLUDE ${UNBOUND_INCLUDE_DIR} PARENT_SCOPE)
set(UNBOUND_LIBRARY ${UNBOUND_LIBRARIES} PARENT_SCOPE)
ELSE()
- MESSAGE(FATAL_ERROR "${BoldRed}Found libunbound includes, but could not find libunbound library. Please make sure you have installed libunbound or libunbound-dev or the equivalent${ColourReset}")
+ die("Found libunbound includes, but could not find libunbound library. Please make sure you have installed libunbound or libunbound-dev or the equivalent")
ENDIF()
ENDIF()