aboutsummaryrefslogtreecommitdiff
path: root/contrib/otshell_utils/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/otshell_utils/CMakeLists.txt')
-rw-r--r--contrib/otshell_utils/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/contrib/otshell_utils/CMakeLists.txt b/contrib/otshell_utils/CMakeLists.txt
new file mode 100644
index 000000000..7413e0dc5
--- /dev/null
+++ b/contrib/otshell_utils/CMakeLists.txt
@@ -0,0 +1,14 @@
+cmake_minimum_required (VERSION 2.6)
+project (otshell CXX)
+
+# Add executable
+
+file(GLOB otshell_utils_sources # All files in directory:
+ "*.h"
+ "*.hpp"
+ "*.cpp"
+)
+
+add_library (otshell_utils STATIC ${otshell_utils_sources})
+set_target_properties (otshell_utils PROPERTIES OUTPUT_NAME "otshell_utils")
+#target_link_libraries (upnpc-static ${LDLIBS}) # to add used libs