aboutsummaryrefslogtreecommitdiff
path: root/contrib/depends/packages/unwind.mk
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--contrib/depends/packages/unwind.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/contrib/depends/packages/unwind.mk b/contrib/depends/packages/unwind.mk
new file mode 100644
index 000000000..06e142115
--- /dev/null
+++ b/contrib/depends/packages/unwind.mk
@@ -0,0 +1,20 @@
+package=unwind
+$(package)_version=1.2
+$(package)_download_path=http://download.savannah.nongnu.org/releases/libunwind
+$(package)_file_name=lib$(package)-$($(package)_version).tar.gz
+$(package)_sha256_hash=1de38ffbdc88bd694d10081865871cd2bfbb02ad8ef9e1606aee18d65532b992
+
+define $(package)_config_cmds
+ $($(package)_autoconf) --disable-shared --enable-static
+endef
+
+define $(package)_build_cmds
+ $(MAKE)
+endef
+
+define $(package)_stage_cmds
+ $(MAKE) DESTDIR=$($(package)_staging_dir) install
+endef
+
+define $(package)_postprocess_cmds
+endef