aboutsummaryrefslogtreecommitdiff
path: root/contrib/depends/packages/hidapi-darwin.mk
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--contrib/depends/packages/hidapi-darwin.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/contrib/depends/packages/hidapi-darwin.mk b/contrib/depends/packages/hidapi-darwin.mk
new file mode 100644
index 000000000..1fbbb59e0
--- /dev/null
+++ b/contrib/depends/packages/hidapi-darwin.mk
@@ -0,0 +1,23 @@
+package=hidapi-darwin
+$(package)_version=0.8.0-rc1
+$(package)_download_path=https://github.com/signal11/hidapi/archive
+$(package)_file_name=hidapi-$($(package)_version).tar.gz
+$(package)_sha256_hash=3c147200bf48a04c1e927cd81589c5ddceff61e6dac137a605f6ac9793f4af61
+
+define $(package)_set_vars
+$(package)_config_opts=--enable-static
+$(package)_config_opts+=--prefix=$(host_prefix)
+endef
+
+define $(package)_config_cmds
+ ./bootstrap &&\
+ $($(package)_autoconf) $($(package)_config_opts) RANLIB="$(host_prefix)/native/bin/x86_64-apple-darwin11-ranlib" AR="$(host_prefix)/native/bin/x86_64-apple-darwin11-ar"
+endef
+
+define $(package)_build_cmds
+ $(MAKE)
+endef
+
+define $(package)_stage_cmds
+ $(MAKE) DESTDIR=$($(package)_staging_dir) install
+endef