aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 316fd7ed8..57dec93c8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -111,6 +111,24 @@ function (add_definition_if_library_exists library function header var)
endif()
endfunction()
+option(RELINK_TARGETS "Relink targets, when just a dependant .so changed, but not its header?" OFF)
+function (monero_set_target_no_relink target)
+ if (RELINK_TARGETS MATCHES OFF)
+ # Will not relink the target, when just its dependant .so has changed, but not it's interface
+ set_target_properties("${target}" PROPERTIES LINK_DEPENDS_NO_SHARED true)
+ endif()
+endfunction()
+
+function (monero_add_minimal_executable name)
+ source_group("${name}"
+ FILES
+ ${ARGN})
+
+ add_executable("${name}"
+ ${ARGN})
+ monero_set_target_no_relink( ${name} )
+endfunction()
+
if(NOT CMAKE_BUILD_TYPE)
set(CMAKE_BUILD_TYPE Release CACHE STRING "Build type" FORCE)
message(STATUS "Setting default build type: ${CMAKE_BUILD_TYPE}")