aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 2 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6a2c66bc8..1f8222a35 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -84,6 +84,8 @@ if (UNIX AND NOT APPLE)
find_package(Threads)
endif()
+find_package(Unbound REQUIRED)
+
if(MSVC)
add_definitions("/bigobj /MP /W3 /GS- /D_CRT_SECURE_NO_WARNINGS /wd4996 /wd4345 /D_WIN32_WINNT=0x0600 /DWIN32_LEAN_AND_MEAN /DGTEST_HAS_TR1_TUPLE=0 /FIinline_c.h /D__SSE4_1__")
# set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} /Dinline=__inline")
@@ -197,11 +199,6 @@ else()
add_custom_target(version ALL)
endif()
-# <expletive deleted> CMake bug making this not work.
-#find_package(Unbound REQUIRED)
-# Won't make sure this works, because that's broken.
-set(CMAKE_UNBOUND_LIB "-lunbound")
-
add_subdirectory(external)
# Final setup for miniupnpc