aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8f2bdc78a..a02f62e62 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -563,10 +563,12 @@ else()
add_cxx_flag_if_supported(-Wformat-security CXX_SECURITY_FLAGS)
# -fstack-protector
- add_c_flag_if_supported(-fstack-protector C_SECURITY_FLAGS)
- add_cxx_flag_if_supported(-fstack-protector CXX_SECURITY_FLAGS)
- add_c_flag_if_supported(-fstack-protector-strong C_SECURITY_FLAGS)
- add_cxx_flag_if_supported(-fstack-protector-strong CXX_SECURITY_FLAGS)
+ if (NOT WIN32)
+ add_c_flag_if_supported(-fstack-protector C_SECURITY_FLAGS)
+ add_cxx_flag_if_supported(-fstack-protector CXX_SECURITY_FLAGS)
+ add_c_flag_if_supported(-fstack-protector-strong C_SECURITY_FLAGS)
+ add_cxx_flag_if_supported(-fstack-protector-strong CXX_SECURITY_FLAGS)
+ endif()
# linker
if (NOT WIN32)