aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d63b50510..b11d6ba6f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -768,3 +768,11 @@ option(BUILD_GUI_DEPS "Build GUI dependencies." OFF)
option(INSTALL_VENDORED_LIBUNBOUND "Install libunbound binary built from source vendored with this repo." OFF)
+include(CheckCCompilerFlag)
+
+CHECK_C_COMPILER_FLAG(-std=c11 HAVE_C11)
+
+include(CheckLibraryExists)
+
+check_library_exists(c memset_s "string.h" HAVE_MEMSET_S)
+check_library_exists(c explicit_bzero "strings.h" HAVE_EXPLICIT_BZERO)