aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 494abb295..66f4d0363 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -155,7 +155,9 @@ add_library(l3 OBJECT incorrect_source.cpp)
file(REMOVE_RECURSE "${TEST_PROJECT}")
endforeach()
endfunction()
-forbid_undefined_symbols()
+if (NOT (CMAKE_SYSTEM_NAME MATCHES "kOpenBSD.*|OpenBSD.*"))
+ forbid_undefined_symbols()
+endif()
if (MINGW)
function(export_all_symbols)