aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3d53e049e..971c097ff 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -689,6 +689,16 @@ endif()
include(version.cmake)
+find_path(ZMQ_INCLUDE_PATH zmq.hpp)
+find_library(ZMQ_LIB zmq)
+
+if(NOT ZMQ_INCLUDE_PATH)
+ message(FATAL_ERROR "Could not find required header zmq.hpp")
+endif()
+if(NOT ZMQ_LIB)
+ message(FATAL_ERROR "Could not find require libzmq")
+endif()
+
function (treat_warnings_as_errors dirs)
foreach(dir ${ARGV})
set_property(DIRECTORY ${dir}